Resolved
We are still observing our systems, but systems now appear to be functioning normally
Monitoring
A fix for this issue has been implemented and we're now monitoring this service to ensure this incident is over.
Identified
We've identified a set of changes relating to access control in regards to payroll modifications. We're going to temporarily roll these back shortly while we look for a singular fix.
The transaction issue is unrelated, however it is causing P&L reporting on jobs to show some incorrect data. A backfill script is currently being worked on to correct this for current and historic data.
Investigating
We're currently aware that payroll modifications are inaccessible, and transactions may not be showing subsequent values correctly within job, client and org P&L reports. We're looking into this.