Resolved
We're seeing the queue return to pre-issue levels. Financial information should now be showing with the expected amount of lag (~5 min)
Monitoring
Transaction history has been caught in the queue rather than being processed. We've pushed a fix through to remediate this issue and are now monitoring the queue to make sure overall values trend down.
We'll continue monitoring.