Resolved
Our upstream provider has declared the incident over, which matches our metrics.
Monitoring
An upstream provider was experiencing a DDOS attack. Service has been restored but we are monitoring for further impact
Identified
The cause has been traced to a DDOS attack on another client of an upstream provider. Mitigations are being put in place to absorb this.
Investigating
We're experiencing issues with our VPN network which is causing issues for users on the Secure network & RDS systems. Non VPN-backed networks are still operational
Our MSP is investigating the cause of this incident