Resolved
This issue has been resolved! Performance has returned to pre-issue levels
Monitoring
Performance has recovered to workable levels. We're replicating back to our main server array before our maintenance window this evening at 5:30 PM GMT - performance will remain at this level until then.
Identified
We've identified a problem with our physical infrastructure in regards to the RDS environment. We're working on a fix to resolve this, which will occur within the next maintenance window
Investigating
We're investigating reports of slow performance across our RDS environment.